Symptom

You are seeing the below error message on your company's Integration Status, or on your Desktop Sync App.

The type initializer for 'OCRex.Integration.Desktop.Sage50.Client.SageDesktopClient' threw an exception.

Applies To

  • Sage 50 users

Cause

This is an internal error code which would require you to do a manual restart of your Desktop Sync App, and a data re-sync of the company.

Resolution

To clear this error, please do the following:

  1. Open your PC's Task Manager, select More details if it is showing the minimised view, and click on the Processes tab.

  2. Click on OCRex.Desktop.AutoEntry.Client & AutoEntry.Service.

  3. Select End Task on both.

  4. Open the Sync App again and ensure you are able to view your company list.

5. Re-sync your company data on AutoEntry.

Once done, check the Integration Status on your AutoEntry homepage again, and the error should be gone!

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