Symptom

The user is receiving the error below on their invoice after publishing.

The document date cannot be before the end of year lock date, currently set at xx/xx/xxxx

Applies To

  • Xero users who have published invoices from the Purchases/Sales folder.

Cause

This error will occur when an invoice is prevented from publishing to Xero due to the invoice date being on or before the current year-end lock date set in Xero.

Resolution

To clear this error, you will need to unpublish the invoice on AutoEntry, edit the date of the invoice to be within the allowed date range and then republish.

Alternatively, you can amend the end of year lock date in Xero prior to unpublishing and republishing this invoice.

Additional Information

  • For more information on setting lock dates within Xero, please click here.

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