Symptom

The user is receiving the below error message when attempting to publish an invoice.

The selected Department: 'xxxx' is not valid for Account Code: 'xxxx'

Applies To

  • Sage 50 Canada users.

Cause

This error occurs if the nominal code is not allowed to be used with a certain Department or vice versa in Sage.

Resolution

This can be checked in the following ways:

Method 1

  1. Go to the company in Sage, open the Chart of Accounts, select the required General Ledger account and open the Departments tab.

  2. Here you will need to verify that the particular Department used with this Account is showing in box on the right hand side.


Method 2

  1. Go to Setup > Settings > General (Accounts) > Departments.

  2. Select the required department and click on the button Assign Accounts.

  3. Here you will see all the Accounts that do not use this department on the left and Accounts that use this department on the right.

You will need to change the settings to allow that particular Department to be used with the correct General Ledger account. This can be done with one of the methods above.

Once done, re-sync your company data on AutoEntry, and re-publish the affected invoices.

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