Symptom
You didn’t select the correct Chart of Accounts template prior to posting some batches to an account, and are receiving the error message 'Can’t reset because there’s transactional data.' after deleting the postings and attempting to change the template.
Cause
This issue can occur as a result of not permanently deleting the postings from the All Batches folder.
Resolution
To resolve this, follow the steps below:
Go to Accounting > All Batches > Deleted.
Click into each folder, and select Permanently delete.
If you can’t see this option, you’ll need to be granted access via User Permissions by the AutoEntry account holder.
Once done, you’ll be able to select the correct template for the Chart of Accounts.