All Collections
Troubleshooting
Error: 'QB Desktop ErrorMessage: A QuickBooks company data file is already open and it is different from the one requested or there are multiple company files open.'
Error: 'QB Desktop ErrorMessage: A QuickBooks company data file is already open and it is different from the one requested or there are multiple company files open.'

How to clear the 'data file is already open' error message for QuickBooks Desktop integrated companies.

AutoEntry Support Team avatar
Written by AutoEntry Support Team
Updated over a week ago

Symptom

You are seeing the below error message on your company's integration status, or on your Desktop Sync App.

QB Desktop ErrorMessage: A QuickBooks company data file is already open and it is different from the one requested or there are multiple company files open.

Cause

If you are getting the following error below it is due to multiple users working on the same QuickBooks file.

Resolution

To clear this error, please follow these steps:

  1. Ask all users to close QuickBooks (including yourself).

  2. Once this is done, only you should sign back into the company file.

  3. After this, please attempt to publish an invoice.

Additional Information

  • The error message will only clear after an invoice is successfully published to QuickBooks.

Did this answer your question?