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Error: (405) Method Not Allowed

How to clear the error "Method not allowed" in AutoEntry.

Marie-H avatar
Written by Marie-H
Updated over 3 weeks ago

Symptom

The following error can appear in the Integrate page or under the Integration Status column in your Companies list.

The remote server returned an error: (405) Method Not Allowed.


Cause

If you integrate with Sage Accounting Start, it will return this error if you've tried to publish a Purchase invoice to your Sage account. The Purchase invoice feature isn’t present in Sage Accounting Start, preventing you from publishing from AutoEntry.

📎NOTE: It will also show the error Action restricted for Start in United Kingdom/Ireland in the Inbox, when trying to publish a purchase invoice.

To avoid this error, you need to make sure you mark those invoices as Paid in AutoEntry before you publish them. This will allow you to publish them directly as payments transactions in your Sage bank account.

📎NOTE: Alternatively, you can upgrade your Sage Accounting Start account to be able to manage unpaid Purchases invoices.


Resolution

The error will clear once you successfully publish an invoice.

  1. Publish the invoice.

📎NOTE: The error will also clear if you trigger a Re-Sync, or if you reconnect the integration, but this isn’t necessary.

📌TIP: You can set up a default payment method from your suppliers settings. It will apply automatically whenever you select that supplier in the invoice.

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