Symptom
You are receiving the below error message when attempting to publish an invoice.
Please Select a Non-Stock Item from Integration Screen , if there are no items in dropdown. please create a new in your AccountsIq Account
Cause
This error is thrown when you have either not allocated a Non-Stock Item on your company's Integrate page.
Resolution
To clear this error, you will first need to click on the Integrate tab, located on the left hand side of your company's homepage.
On the Integrate page, your Non-Stock Items drop-down menu may be empty as shown below:
If this is the case, it may be due to the way you set up your Non-Stock Items in AIQ. To check this, please navigate to the Items tab in AIQ, and ensure that your Active item is set to 'Non-Stock'. If it is set to Service, it will not sync through to AutoEntry.
Once done, re-sync your company data on the AutoEntry website, allocate a Non-Stock Item on the Integrate page, click Save, and the error should clear from your invoice!
Last edited:
Apr 27, 2023, 07:00 AM