When attempting to publish a purchase invoice from AutoEntry to Xero Ledger, the following error will occur:
" Information - Invoice [number] has been published to your accounting software but attachment could not be uploaded; please manually attach document in accounting software."
However, when checking in Xero, the invoice doesn’t appear in Purchases.
Cause
This issue occurs because Xero Ledger doesn’t support Accounts Payable (Purchases / Bills).
Since the Xero Ledger subscription type doesn’t include the Purchases (Bills) feature, AutoEntry can't post purchase invoices into Xero Ledger.
📎NOTE: If you're not integrated with Xero Ledger, this error can also occur when the attachment is larger than your software specification. Also if you're integrated with Xero Cashbook, you can't post attachments from external software.
In both scenarios, you'll need to post the attachments directly onto the accounting software.
Resolution
You have two options available to resolve this:
Option 1 - Upgrade your Xero subscription
To enable invoice posting from AutoEntry, you’ll need to move from Xero Ledger to a subscription that supports Accounts Payable. For example: Xero Cashbook, Xero Business editions – Starter, Standard, or Premium.
Option 2 - Manual Export
If upgrading isn’t an option, you can download the invoices from AutoEntry as PDF or CSV and manually upload them into Xero Ledger.