All Collections
Troubleshooting
Error: 'Xero API error calling GetInvoices'
Error: 'Xero API error calling GetInvoices'

How to clear the Xero error 'Error occurred while checking for duplicate invoice. Error :Xero API error calling GetInvoices:'

Nathan avatar
Written by Nathan
Updated over a week ago

Symptom

You are seeing the below error message when attempting to publish an invoice.

Error occurred while checking for duplicate invoice. Error :Xero API error calling GetInvoices:{"Type":null,"Title":"Forbidden", "Status":403,"Detail": AuthenticationUnsuccessful","Instance".......

Applies To

  • Xero integrated companies.

Cause

This error message is due to a limit imposed by Xero's API, which prevents 40 or more invoices from being posted at one time. The queueing system for invoices to be published to Xero should renew itself once the limit has been exceeded, and AutoEntry will attempt to push the invoices across itself, with no interference from the user required. However, if you still receive the error message, please read below.

Resolution

To clear this error, please do the following:

  1. Disconnect and reconnect your integration.

  2. Republish any affected invoices.

Additional Information

  • For more information on this API limitation, please click here to be redirected to Xero's site.

  • If you are receiving an 'Already Connected' message when reconnecting to Xero, please follow these steps.

Did this answer your question?