Symptom
You are seeing the below error message on an invoice after attempting to publish it to Xero. For illustrative purposes here, we will use Euro as the currency.
Organisation is not subscribed to currency EUR
Applies To
Xero integrated companies.
Purchase/Sales Invoices.
Cause
Your Xero company does not have the stated currency added to it within the Settings.
Resolution
To clear this error message, you will need to do the following:
Open your company in Xero.
Go to Settings.
Click Currencies.
Click + Add Currency.
Select EUR using the drop-down menu, and click Add Currency.
Go back to AutoEntry and re-sync your company's Xero data.
Unpublish the invoice, and attempt to publish it again.
Additional Information
Some information on how AutoEntry deals with currency conversion and selection can be found here.